Suspected Firewall Issues
If your Salesforce environment or IDE is protected by a Firewall that may block DigitSec from scanning or connecting with your work environment, please consider making modifications to whitelist our systems.
Our Public NAT addresses for scanning are: 34.86.175.68 and 35.247.15.76
For guidance on whitelisting IP addresses on Salesforce, click here.
For the IDE, please whitelist the host: s4.digitsec.com
Help with common errors:
- Infinite Refreshing or /error?error=OAUTH_APP_BLOCKED in browser location bar
This error occurs if a DigitSec is blocked under the Salesforce Connected Apps OAuth Usage setting panel. Please login to Salesforce as an Administrator. Under the Setup Quick Find, access Connected Apps OAuth Usage page. Search for a listing of S4 and click the "Unblock" button. That should remove it from the list and you should now be able to complete the authorization process to create a connected Workspace.
- invalid_grant: expired access/refresh token
This error occurs when the Salesforce issued access token and refresh token for S4 becomes invalid due to a change in the Salesforce configuration. This can be fixed by editing the org in S4 and authorizing a new access and refresh token.
- {"error":true,"message":"{"error":"unsupported_grant_type","error_description":"grant type not supported"}}
This error occurs when a user attempts to add an org to S4 using an instance URL ending in lightning.force.com. The instance URL should be in the format of https://*.my.salesforce.com, where * is your sub domain. (Note: Do not use *.lightning.force.com URL here)
- Polling time out. Process Id = {ID}
This error occurs when Salesforce doesn't resolve and return source code to S4. This can occur periodically due to connectivity. This issue can be resolved by retrying. If you are still having issues please reach out to us. Support
- Destination URL not reset. The URL returned from login must be set in the SforceService
This error occurs when the consumer key is invalid or access has expired. Please, edit the Salesforce org details and grant access to S4 again.
- API Not Enabled Error
Enable API in your org so that S4 can obtain source code.
CAUSE:
The Salesforce account that the user is trying to create a connection to does not have the API feature enabled. To use the API, the Salesforce account or the organization must be on one of the following three editions (note that this feature is enabled by default):
1. Enterprise Edition
2. Unlimited Edition
3. Developer Edition
- CLIENT_NOT_ACCESSIBLE_FOR_USER: Sorry, your administrator has blocked access to this client.
This error occurs when a user no longer has access to the Salesforce environment. Check the user profile and permission set to ensure the user has the S4 app enabled.
The API package is not available for the following editions:
1. Personal Edition(including trial account)
2. Group Edition
3. Professional Edition
ACTION:
The user will have to contact Salesforce for information on either upgrading their Salesforce account so DigitSec can access the API or to use an existing Salesforce account that has API privileges enabled.
NOTE: If you have an org that has API Access Enabled then the user profile does not have API Access Enabled. You can enable that in the Profile section and then try to run a Security Scan.